[Buildroot] [PATCH] libinput: remove unneeded patch

Subsystems: the rest

6 messages, 3 authors, 2016-05-13 · open the first message on its own page

[Buildroot] [PATCH] libinput: remove unneeded patch

From: Baruch Siach <baruch@tkos.co.il>
Date: 2016-05-13 06:09:52

The log_msg symbol conflict was fixed in libevdev commit e4c315fc1603 (Rename
symbols leaking from static library to avoid name clashes, 2014-08-18) that
was included in version 1.3. Remove the patch that used to fix this issue.

Cc: Romain Naour <redacted>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
---
 .../0001-rename-log_msg-to-libinput_log_msg.patch  | 77 ----------------------
 1 file changed, 77 deletions(-)
 delete mode 100644 package/libinput/0001-rename-log_msg-to-libinput_log_msg.patch
diff --git a/package/libinput/0001-rename-log_msg-to-libinput_log_msg.patch b/package/libinput/0001-rename-log_msg-to-libinput_log_msg.patch
deleted file mode 100644
index e36862a12da6..000000000000
--- a/package/libinput/0001-rename-log_msg-to-libinput_log_msg.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-From bf4a4a4e2b0479322fe16c9e1f15f146daa893ee Mon Sep 17 00:00:00 2001
-From: Romain Naour <romain.naour@openwide.fr>
-Date: Thu, 21 Aug 2014 18:18:16 +0200
-Subject: [PATCH] rename log_msg to libinput_log_msg
-
-This fixes a conflict between libevdev and libinput on the definition
-of the log_msg() symbol.
-
-http://autobuild.buildroot.net/results/c13/c133b7c706ee31302125df8ca94f4d0f0152c6c6/build-end.log
-
-Signed-off-by: Romain Naour <romain.naour@openwide.fr>
-[yann.morin.1998 at free.fr: rebase on-top of 0.6.0]
-Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
-[ps.report at gmx.net: rebase on top of 0.7.0]
-Signed-off-by: Peter Seiderer <ps.report@gmx.net>
----
- src/libinput-private.h | 14 +++++++-------
- src/libinput.c         |  2 +-
- 2 files changed, 8 insertions(+), 8 deletions(-)
-
-diff --git a/src/libinput-private.h b/src/libinput-private.h
-index b36dc95..98f91b3 100644
---- a/src/libinput-private.h
-+++ b/src/libinput-private.h
-@@ -259,12 +259,12 @@
- 
- typedef void (*libinput_source_dispatch_t)(void *data);
- 
--#define log_debug(li_, ...) log_msg((li_), LIBINPUT_LOG_PRIORITY_DEBUG, __VA_ARGS__)
--#define log_info(li_, ...) log_msg((li_), LIBINPUT_LOG_PRIORITY_INFO, __VA_ARGS__)
--#define log_error(li_, ...) log_msg((li_), LIBINPUT_LOG_PRIORITY_ERROR, __VA_ARGS__)
--#define log_bug_kernel(li_, ...) log_msg((li_), LIBINPUT_LOG_PRIORITY_ERROR, "kernel bug: " __VA_ARGS__)
--#define log_bug_libinput(li_, ...) log_msg((li_), LIBINPUT_LOG_PRIORITY_ERROR, "libinput bug: " __VA_ARGS__)
--#define log_bug_client(li_, ...) log_msg((li_), LIBINPUT_LOG_PRIORITY_ERROR, "client bug: " __VA_ARGS__)
-+#define log_debug(li_, ...) libinput_log_msg((li_), LIBINPUT_LOG_PRIORITY_DEBUG, __VA_ARGS__)
-+#define log_info(li_, ...) libinput_log_msg((li_), LIBINPUT_LOG_PRIORITY_INFO, __VA_ARGS__)
-+#define log_error(li_, ...) libinput_log_msg((li_), LIBINPUT_LOG_PRIORITY_ERROR, __VA_ARGS__)
-+#define log_bug_kernel(li_, ...) libinput_log_msg((li_), LIBINPUT_LOG_PRIORITY_ERROR, "kernel bug: " __VA_ARGS__)
-+#define log_bug_libinput(li_, ...) libinput_log_msg((li_), LIBINPUT_LOG_PRIORITY_ERROR, "libinput bug: " __VA_ARGS__)
-+#define log_bug_client(li_, ...) libinput_log_msg((li_), LIBINPUT_LOG_PRIORITY_ERROR, "client bug: " __VA_ARGS__)
- 
- #define log_debug_ratelimit(li_, r_, ...) log_msg_ratelimit((li_), (r_), LIBINPUT_LOG_PRIORITY_DEBUG, __VA_ARGS__)
- #define log_info_ratelimit(li_, r_, ...) log_msg_ratelimit((li_), (r_), LIBINPUT_LOG_PRIORITY_INFO, __VA_ARGS__)
-@@ -281,7 +281,7 @@
- 	LIBINPUT_ATTRIBUTE_PRINTF(4, 5);
- 
- void
--log_msg(struct libinput *libinput,
-+libinput_log_msg(struct libinput *libinput,
- 	enum libinput_log_priority priority,
- 	const char *format, ...)
- 	LIBINPUT_ATTRIBUTE_PRINTF(3, 4);
-diff --git a/src/libinput.c b/src/libinput.c
-index 279cce0..5748e5e 100644
---- a/src/libinput.c
-+++ b/src/libinput.c
-@@ -155,7 +155,7 @@
- }
- 
- void
--log_msg(struct libinput *libinput,
-+libinput_log_msg(struct libinput *libinput,
- 	enum libinput_log_priority priority,
- 	const char *format, ...)
- {
-@@ -184,7 +184,7 @@
- 	va_end(args);
- 
- 	if (state == RATELIMIT_THRESHOLD)
--		log_msg(libinput,
-+		libinput_log_msg(libinput,
- 			priority,
- 			"WARNING: log rate limit exceeded (%d msgs per %dms). Discarding future messages.\n",
- 			ratelimit->burst,
--- 
-2.1.2
-
-- 
2.8.1

[Buildroot] [PATCH] libinput: remove unneeded patch

From: Peter Korsgaard <peter@korsgaard.com>
Date: 2016-05-13 07:40:30

quoted
quoted
quoted
quoted
"Baruch" == Baruch Siach [off-list ref] writes:
 > The log_msg symbol conflict was fixed in libevdev commit e4c315fc1603 (Rename
 > symbols leaking from static library to avoid name clashes, 2014-08-18) that
 > was included in version 1.3. Remove the patch that used to fix this issue.

Ehh, but we are still on 1.2.4. Shouldn't this go together with the
version bump to 1.3?

-- 
Bye, Peter Korsgaard

[Buildroot] [PATCH] libinput: remove unneeded patch

From: Baruch Siach <baruch@tkos.co.il>
Date: 2016-05-13 07:56:25

Hi Peter,

On Fri, May 13, 2016 at 09:09:52AM +0300, Baruch Siach wrote:
The log_msg symbol conflict was fixed in libevdev commit e4c315fc1603 (Rename
symbols leaking from static library to avoid name clashes, 2014-08-18) that
was included in version 1.3. Remove the patch that used to fix this issue.
I meant libevdev version in this last line, since it's a libevdev commit. 
We're at 1.4.6 on that.

baruch

-- 
     http://baruch.siach.name/blog/                  ~. .~   Tk Open Systems
=}------------------------------------------------ooO--U--Ooo------------{=
   - baruch at tkos.co.il - tel: +972.2.679.5364, http://www.tkos.co.il -

[Buildroot] [PATCH] libinput: remove unneeded patch

From: Thomas Petazzoni <hidden>
Date: 2016-05-13 13:23:14

Hello,

On Fri, 13 May 2016 10:56:25 +0300, Baruch Siach wrote:
Hi Peter,

On Fri, May 13, 2016 at 09:09:52AM +0300, Baruch Siach wrote:
quoted
The log_msg symbol conflict was fixed in libevdev commit e4c315fc1603 (Rename
symbols leaking from static library to avoid name clashes, 2014-08-18) that
was included in version 1.3. Remove the patch that used to fix this issue.  
I meant libevdev version in this last line, since it's a libevdev commit. 
We're at 1.4.6 on that.
You're already saying "libevdev" in your commit log. But the fact that
you're removing a patch from libinput is not clear. I guess it's
because libinput links against libevdev, but this should be made
clearer in your commit message.

Thanks,

Thomas
-- 
Thomas Petazzoni, CTO, Free Electrons
Embedded Linux, Kernel and Android engineering
http://free-electrons.com

[Buildroot] [PATCH] libinput: remove unneeded patch

From: Baruch Siach <baruch@tkos.co.il>
Date: 2016-05-13 13:48:18

Hi Thomas,

On Fri, May 13, 2016 at 03:23:14PM +0200, Thomas Petazzoni wrote:
On Fri, 13 May 2016 10:56:25 +0300, Baruch Siach wrote:
quoted
On Fri, May 13, 2016 at 09:09:52AM +0300, Baruch Siach wrote:
quoted
The log_msg symbol conflict was fixed in libevdev commit e4c315fc1603 (Rename
symbols leaking from static library to avoid name clashes, 2014-08-18) that
was included in version 1.3. Remove the patch that used to fix this issue.  
I meant libevdev version in this last line, since it's a libevdev commit. 
We're at 1.4.6 on that.
You're already saying "libevdev" in your commit log. But the fact that
you're removing a patch from libinput is not clear. I guess it's
because libinput links against libevdev, but this should be made
clearer in your commit message.
I see. It's just that the patch being removed itself says:

  This fixes a conflict between libevdev and libinput on the definition
  of the log_msg() symbol.

So I thought is should be self evident.

Should I respin with a clearer commit log?

Thanks for reviewing,
baruch

-- 
     http://baruch.siach.name/blog/                  ~. .~   Tk Open Systems
=}------------------------------------------------ooO--U--Ooo------------{=
   - baruch at tkos.co.il - tel: +972.2.679.5364, http://www.tkos.co.il -

[Buildroot] [PATCH] libinput: remove unneeded patch

From: Thomas Petazzoni <hidden>
Date: 2016-05-13 13:56:32

Hello,

On Fri, 13 May 2016 16:48:18 +0300, Baruch Siach wrote:
I see. It's just that the patch being removed itself says:

  This fixes a conflict between libevdev and libinput on the definition
  of the log_msg() symbol.
Hm, right.
Should I respin with a clearer commit log?
I guess it would be good, since Peter was also confused by your commit
log.

Thanks a lot!

Thomas
-- 
Thomas Petazzoni, CTO, Free Electrons
Embedded Linux, Kernel and Android engineering
http://free-electrons.com
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help