Reviews by mark.rutland@arm.com
· bpf
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the bpf archive.
76 attestations . (53 Acked-by, 6 Co-developed-by, 5 Reported-by, 4 Reviewed-by, 1 Suggested-by, 7 Tested-by)
-
STALE139d
REVIEWED: 7 (7M) [PATCH 6.12 068/385] ftrace: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2026-02-28 · Acked-by -
DORMANTno replies
REVIEWED: 7 (7M) [for-next][PATCH 3/3] ftrace: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-10-15 · Acked-by -
STALE635d
LANDED: 7 (7M) [PATCH v16 02/18] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-10-15 · Acked-by -
STALE635d
REVIEWED: 7 (7M) Re: [PATCH v2] arm64: insn: Simulate nop instruction for better uprobe performance
2024-10-10 · Acked-by -
STALE647d
REVIEWED: 7 (7M) [PATCH v15 02/19] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-09-15 · Acked-by -
STALE647d
REVIEWED: 7 (7M) [PATCH v15 01/19] tracing: Add a comment about ftrace_regs definition
2024-09-15 · Acked-by -
STALE654d
REVIEWED: 7 (7M) [PATCH v14 02/19] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-09-12 · Acked-by -
STALE654d
REVIEWED: 7 (7M) [PATCH v14 01/19] tracing: Add a comment about ftrace_regs definition
2024-09-12 · Acked-by -
STALE675d
REVIEWED: 7 (7M) [PATCH v13 03/20] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-08-18 · Acked-by -
STALE675d
REVIEWED: 7 (7M) [PATCH v13 02/20] tracing: Add a comment about ftrace_regs definition
2024-08-18 · Acked-by -
STALE745d
REVIEWED: 7 (7M) [PATCH v12 02/19] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-07-03 · Acked-by -
STALE745d
REVIEWED: 7 (7M) [PATCH v12 01/19] tracing: Add a comment about ftrace_regs definition
2024-07-03 · Acked-by -
STALE753d
REVIEWED: 7 (7M) [PATCH v11 02/18] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-06-17 · Acked-by -
STALE753d
REVIEWED: 7 (7M) [PATCH v11 01/18] tracing: Add a comment about ftrace_regs definition
2024-06-17 · Acked-by -
STALE784d
REVIEWED: 7 (7M) [PATCH v10 02/36] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-05-07 · Acked-by -
STALE784d
REVIEWED: 7 (7M) [PATCH v10 01/36] tracing: Add a comment about ftrace_regs definition
2024-05-07 · Acked-by -
STALE795d
REVIEWED: 7 (7M) [PATCH 11/48] bpf: Select new NEED_TASKS_RCU Kconfig option
2024-05-07 · Acked-by -
STALE766d
LANDED: 7 (7M) [PATCH v3 2/2] arm64: implement raw_smp_processor_id() using thread_info
2024-05-03 · Acked-by -
STALE766d
LANDED: 7 (7M) [PATCH v3 1/2] arm64/arch_timer: include <linux/percpu.h>
2024-05-03 · Acked-by -
STALE803d
REVIEWED: 7 (7M) Re: [PATCH v2 2/2] arm64: implement raw_smp_processor_id() using thread_info
2024-05-03 · Acked-by -
STALE803d
REVIEWED: 7 (7M) Re: [PATCH v2 1/2] arm64/arch_timer: include <linux/percpu.h>
2024-05-03 · Acked-by -
STALE802d
REVIEWED: 7 (7M) [PATCH v9 02/36] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-04-15 · Acked-by -
STALE802d
REVIEWED: 7 (7M) [PATCH v9 01/36] tracing: Add a comment about ftrace_regs definition
2024-04-15 · Acked-by -
STALE872d
REVIEWED: 7 (7M) [PATCH v8 02/35] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-02-25 · Acked-by -
STALE872d
REVIEWED: 7 (7M) [PATCH v8 01/35] tracing: Add a comment about ftrace_regs definition
2024-02-25 · Acked-by -
STALE870d
LANDED: 1 (1M) [PATCH v6] bpf: Replace bpf_lpm_trie_key 0-length array with flexible array
2024-02-22 · Reported-by -
STALE877d
REVIEWED: 1 (1M) [PATCH v5] bpf: Replace bpf_lpm_trie_key 0-length array with flexible array
2024-02-21 · Reported-by -
STALE878d
REVIEWED: 1 (1M) [PATCH v4] bpf: Replace bpf_lpm_trie_key 0-length array with flexible array
2024-02-20 · Reported-by -
STALE879d
[PATCH v3] bpf: Replace bpf_lpm_trie_key 0-length array with flexible array
2024-02-19 · Reported-by -
STALE880d
[PATCH v2] bpf: Replace bpf_lpm_trie_key 0-length array with flexible array
2024-02-16 · Reported-by -
STALE880d
REVIEWED: 7 (7M) [PATCH v7 03/36] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-02-06 · Acked-by -
STALE880d
REVIEWED: 7 (7M) [PATCH v7 02/36] tracing: Add a comment about ftrace_regs definition
2024-02-06 · Acked-by -
STALE880d
REVIEWED: 10 (10M) [PATCH v7 01/36] ftrace: Fix DIRECT_CALLS to use SAVE_REGS by default
2024-02-06 · Reviewed-by -
STALE901d
REVIEWED: 7 (7M) [PATCH v6 03/36] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-01-12 · Acked-by -
STALE901d
REVIEWED: 7 (7M) [PATCH v6 02/36] tracing: Add a comment about ftrace_regs definition
2024-01-12 · Acked-by -
STALE901d
REVIEWED: 10 (10M) [PATCH v6 01/36] ftrace: Fix DIRECT_CALLS to use SAVE_REGS by default
2024-01-12 · Reviewed-by -
STALE919d
REVIEWED: 7 (7M) Re: [PATCH v5 22/34] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-01-05 · Acked-by -
STALE919d
REVIEWED: 7 (7M) Re: [PATCH v5 01/34] tracing: Add a comment about ftrace_regs definition
2024-01-05 · Acked-by -
STALE1181d
REVIEWED: 14 (14M) Re: [PATCH v6 4/5] arm64: ftrace: Add direct call trampoline samples support
2023-04-06 · Reviewed-by -
STALE1181d
REVIEWED: 14 (14M) Re: [PATCH v6 4/5] arm64: ftrace: Add direct call trampoline samples support
2023-04-06 · Tested-by -
STALE1181d
REVIEWED: 7 (7M) Re: [PATCH v6 3/5] samples: ftrace: Save required argument registers in sample trampolines
2023-04-06 · Reviewed-by -
STALE1181d
LANDED: 7 (7M) [PATCH v6 2/5] arm64: ftrace: Simplify get_ftrace_plt
2023-04-05 · Acked-by -
STALE1181d
LANDED [PATCH v6 1/5] arm64: ftrace: Add direct call support
2023-04-05 · Co-developed-by -
STALE1201d
REVIEWED: 7 (7M) [PATCH v5 2/4] arm64: ftrace: Simplify get_ftrace_plt
2023-04-03 · Acked-by -
STALE1201d
[PATCH v5 1/4] arm64: ftrace: Add direct call support
2023-04-03 · Co-developed-by -
STALE1202d
REVIEWED: 7 (7M) [PATCH v4 2/4] arm64: ftrace: Simplify get_ftrace_plt
2023-04-03 · Acked-by -
STALE1202d
[PATCH v4 1/4] arm64: ftrace: Add direct call support
2023-04-03 · Co-developed-by -
STALE1209d
REVIEWED: 7 (7M) Re: [PATCH v3 2/4] arm64: ftrace: Simplify get_ftrace_plt
2023-03-24 · Acked-by -
STALE1209d
[PATCH v3 1/4] arm64: ftrace: Add direct call support
2023-03-24 · Co-developed-by -
STALE1220d
[PATCH v2 07/10] arm64: ftrace: Add direct call support
2023-02-07 · Co-developed-by -
STALE1220d
[PATCH v2 05/10] ftrace: Make DIRECT_CALLS work WITH_ARGS and !WITH_REGS
2023-02-07 · Co-developed-by -
STALE1220d
REVIEWED: 14 (14M) [PATCH v2 03/10] ftrace: Rename _ftrace_direct_multi APIs to _ftrace_direct APIs
2023-02-07 · Acked-by -
STALE1220d
REVIEWED: 14 (14M) [PATCH v2 03/10] ftrace: Rename _ftrace_direct_multi APIs to _ftrace_direct APIs
2023-02-07 · Tested-by -
STALE1220d
REVIEWED: 14 (14M) [PATCH v2 02/10] ftrace: Remove the legacy _ftrace_direct API
2023-02-07 · Acked-by -
STALE1220d
REVIEWED: 14 (14M) [PATCH v2 02/10] ftrace: Remove the legacy _ftrace_direct API
2023-02-07 · Tested-by -
STALE1220d
REVIEWED: 14 (14M) [PATCH v2 01/10] ftrace: Replace uses of _ftrace_direct APIs with _ftrace_direct_multi
2023-02-07 · Acked-by -
STALE1220d
REVIEWED: 14 (14M) [PATCH v2 01/10] ftrace: Replace uses of _ftrace_direct APIs with _ftrace_direct_multi
2023-02-07 · Tested-by -
STALE1257d
REVIEWED: 14 (14M) Re: [PATCH 3/8] ftrace: Rename _ftrace_direct_multi APIs to _ftrace_direct APIs
2023-02-02 · Acked-by -
STALE1257d
REVIEWED: 14 (14M) Re: [PATCH 3/8] ftrace: Rename _ftrace_direct_multi APIs to _ftrace_direct APIs
2023-02-02 · Tested-by -
STALE1257d
REVIEWED: 14 (14M) Re: [PATCH 2/8] ftrace: Remove the legacy _ftrace_direct API
2023-02-02 · Acked-by -
STALE1257d
REVIEWED: 14 (14M) Re: [PATCH 2/8] ftrace: Remove the legacy _ftrace_direct API
2023-02-02 · Tested-by -
STALE1257d
REVIEWED: 14 (14M) Re: [PATCH 1/8] ftrace: Replace uses of _ftrace_direct APIs with _ftrace_direct_multi
2023-02-02 · Acked-by -
STALE1257d
REVIEWED: 14 (14M) Re: [PATCH 1/8] ftrace: Replace uses of _ftrace_direct APIs with _ftrace_direct_multi
2023-02-02 · Tested-by -
STALE1257d
[PATCH 7/8] arm64: ftrace: Add direct call support
2023-02-01 · Suggested-by -
DORMANTno replies
REVIEWED: 7 (7M) Re: [PATCH ebpf v3] bpf: Disallow unprivileged bpf by default
2021-11-01 · Acked-by -
STALE1927d
LANDED: 12 (12M) [PATCH v6 16/18] arm64: ftrace: use function_nocfi for ftrace_call
2021-04-08 · Acked-by -
STALE1927d
LANDED: 13 (12M) [PATCH v6 13/18] arm64: use function_nocfi with __pa_symbol
2021-04-08 · Acked-by -
STALE1927d
LANDED: 13 (12M) [PATCH v6 12/18] arm64: implement function_nocfi
2021-04-08 · Acked-by -
STALE1927d
LANDED: 13 (12M) [PATCH v6 11/18] psci: use function_nocfi for cpu_resume
2021-04-08 · Acked-by -
STALE1927d
LANDED: 13 (12M) [PATCH v6 03/18] mm: add generic function_nocfi macro
2021-04-08 · Acked-by -
STALE1929d
REVIEWED: 7 (7M) Re: [PATCH v5 16/18] arm64: ftrace: use function_nocfi for ftrace_call
2021-04-06 · Acked-by -
STALE1929d
REVIEWED: 7 (7M) Re: [PATCH v5 13/18] arm64: use function_nocfi with __pa_symbol
2021-04-06 · Acked-by -
STALE1929d
REVIEWED: 7 (7M) Re: [PATCH v5 12/18] arm64: implement function_nocfi
2021-04-06 · Acked-by -
STALE1929d
REVIEWED: 7 (7M) Re: [PATCH v5 11/18] psci: use function_nocfi for cpu_resume
2021-04-06 · Acked-by -
STALE1929d
REVIEWED: 7 (7M) Re: [PATCH v5 03/18] mm: add generic function_nocfi macro
2021-04-06 · Acked-by -
STALE2284d
REVIEWED: 7 (7M) Re: [PATCH 26/28] arm64: use __vmalloc_node in arch_alloc_vmap_stack
2020-04-08 · Acked-by