The at91sam9260ek has a custom reset function which does the same thing
as the default function. Also it does not define MACH_HAS_LOWLEVEL_INIT
as it should do. Remove the function.
Signed-off-by: Sascha Hauer <s.hauer@pengutronix.de>
---
arch/arm/boards/at91sam9260ek/Makefile | 1 -
arch/arm/boards/at91sam9260ek/lowlevel_init.S | 25 -------------------------
2 files changed, 26 deletions(-)
delete mode 100644 arch/arm/boards/at91sam9260ek/lowlevel_init.S
@@ -1,25 +0,0 @@-/*- * Board specific setup info- *- *- * See file CREDITS for list of people who contributed to this- * project.- *- * This program is free software; you can redistribute it and/or- * modify it under the terms of the GNU General Public License as- * published by the Free Software Foundation; either version 2 of- * the License, or (at your option) any later version.- *- * This program is distributed in the hope that it will be useful,- * but WITHOUT ANY WARRANTY; without even the implied warranty of- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the- * GNU General Public License for more details.- *- */--#include <asm/barebox-arm-head.h>--.globl reset-reset:- common_reset r0- b board_init_lowlevel_return
--
1.7.10.4
_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox
The at91sam9260ek has a custom reset function which does the same thing
as the default function. Also it does not define MACH_HAS_LOWLEVEL_INIT
as it should do. Remove the function.
Signed-off-by: Sascha Hauer <s.hauer@pengutronix.de>
---
Acked-by: Jean-Christophe PLAGNIOL-VILLARD <redacted>
btw we should rename the command reset reboot because it start to be confusing
Best Regards,
J.
_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox
On 8 October 2012 16:15, Jean-Christophe PLAGNIOL-VILLARD
[off-list ref] wrote:
On 13:02 Mon 08 Oct , Sascha Hauer wrote:
quoted
The at91sam9260ek has a custom reset function which does the same thing
as the default function. Also it does not define MACH_HAS_LOWLEVEL_INIT
as it should do. Remove the function.
Signed-off-by: Sascha Hauer <s.hauer@pengutronix.de>
---
Acked-by: Jean-Christophe PLAGNIOL-VILLARD <redacted>
btw we should rename the command reset reboot because it start to be confusing
IMHO it is a very good idea!
--
Best regards,
Antony Pavlov
_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox
On Mon, Oct 08, 2012 at 04:24:18PM +0400, Antony Pavlov wrote:
On 8 October 2012 16:15, Jean-Christophe PLAGNIOL-VILLARD
[off-list ref] wrote:
quoted
On 13:02 Mon 08 Oct , Sascha Hauer wrote:
quoted
The at91sam9260ek has a custom reset function which does the same thing
as the default function. Also it does not define MACH_HAS_LOWLEVEL_INIT
as it should do. Remove the function.
Signed-off-by: Sascha Hauer <s.hauer@pengutronix.de>
---
Acked-by: Jean-Christophe PLAGNIOL-VILLARD <redacted>
btw we should rename the command reset reboot because it start to be confusing
IMHO it is a very good idea!
I would rather use a different name for the reset functions which are in
the startup code. In the end the reset command just resets the board.
'reboot' sounds like something is being shutdown before restarting a
board.
Changing a command is quite painful since all environment scripts will
be broken. I don't think reset is used in the environment, but the
API change to the mount command always nags me when using a new barebox
which has an older environment in flash. I think we really have to be
more careful when changing commands.
Sascha
--
Pengutronix e.K. | |
Industrial Linux Solutions | http://www.pengutronix.de/ |
Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0 |
Amtsgericht Hildesheim, HRA 2686 | Fax: +49-5121-206917-5555 |
_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox
On Mon, Oct 08, 2012 at 04:24:18PM +0400, Antony Pavlov wrote:
quoted
On 8 October 2012 16:15, Jean-Christophe PLAGNIOL-VILLARD
[off-list ref] wrote:
quoted
On 13:02 Mon 08 Oct , Sascha Hauer wrote:
quoted
The at91sam9260ek has a custom reset function which does the same thing
as the default function. Also it does not define MACH_HAS_LOWLEVEL_INIT
as it should do. Remove the function.
Signed-off-by: Sascha Hauer <s.hauer@pengutronix.de>
---
Acked-by: Jean-Christophe PLAGNIOL-VILLARD <redacted>
btw we should rename the command reset reboot because it start to be confusing
IMHO it is a very good idea!
I would rather use a different name for the reset functions which are in
the startup code. In the end the reset command just resets the board.
'reboot' sounds like something is being shutdown before restarting a
board.
Changing a command is quite painful since all environment scripts will
be broken. I don't think reset is used in the environment, but the
API change to the mount command always nags me when using a new barebox
which has an older environment in flash. I think we really have to be
more careful when changing commands.
reset means reset the screen in linux
and I check nearly no one use reset in the env
execpt sam9g45 and defaultenv2
when I ask to do not update the var to pass the arch number on arm you give
the invert comment env evolve and we do not want to loose tis freedom
Best Regards,
J.
_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox
On Wed, Oct 10, 2012 at 11:39:21AM +0200, Jean-Christophe PLAGNIOL-VILLARD wrote:
On 10:46 Wed 10 Oct , Sascha Hauer wrote:
quoted
On Mon, Oct 08, 2012 at 04:24:18PM +0400, Antony Pavlov wrote:
quoted
On 8 October 2012 16:15, Jean-Christophe PLAGNIOL-VILLARD
[off-list ref] wrote:
quoted
On 13:02 Mon 08 Oct , Sascha Hauer wrote:
quoted
The at91sam9260ek has a custom reset function which does the same thing
as the default function. Also it does not define MACH_HAS_LOWLEVEL_INIT
as it should do. Remove the function.
Signed-off-by: Sascha Hauer <s.hauer@pengutronix.de>
---
Acked-by: Jean-Christophe PLAGNIOL-VILLARD <redacted>
btw we should rename the command reset reboot because it start to be confusing
IMHO it is a very good idea!
I would rather use a different name for the reset functions which are in
the startup code. In the end the reset command just resets the board.
'reboot' sounds like something is being shutdown before restarting a
board.
Changing a command is quite painful since all environment scripts will
be broken. I don't think reset is used in the environment, but the
API change to the mount command always nags me when using a new barebox
which has an older environment in flash. I think we really have to be
more careful when changing commands.
reset means reset the screen in linux
and I check nearly no one use reset in the env
execpt sam9g45 and defaultenv2
when I ask to do not update the var to pass the arch number on arm you give
the invert comment env evolve and we do not want to loose tis freedom
You are right, but still we have a problem in this area and I wanted to
mention it. One way out could for example be that we introduce some
version counter which we increase when incompatible changes occur. Then
we could fall back to the default env. I haven't thought that to an end
though.
Sascha
--
Pengutronix e.K. | |
Industrial Linux Solutions | http://www.pengutronix.de/ |
Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0 |
Amtsgericht Hildesheim, HRA 2686 | Fax: +49-5121-206917-5555 |
_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox
On Wed, Oct 10, 2012 at 11:39:21AM +0200, Jean-Christophe PLAGNIOL-VILLARD wrote:
quoted
On 10:46 Wed 10 Oct , Sascha Hauer wrote:
quoted
On Mon, Oct 08, 2012 at 04:24:18PM +0400, Antony Pavlov wrote:
quoted
On 8 October 2012 16:15, Jean-Christophe PLAGNIOL-VILLARD
[off-list ref] wrote:
quoted
On 13:02 Mon 08 Oct , Sascha Hauer wrote:
quoted
The at91sam9260ek has a custom reset function which does the same thing
as the default function. Also it does not define MACH_HAS_LOWLEVEL_INIT
as it should do. Remove the function.
Signed-off-by: Sascha Hauer <s.hauer@pengutronix.de>
---
Acked-by: Jean-Christophe PLAGNIOL-VILLARD <redacted>
btw we should rename the command reset reboot because it start to be confusing
IMHO it is a very good idea!
I would rather use a different name for the reset functions which are in
the startup code. In the end the reset command just resets the board.
'reboot' sounds like something is being shutdown before restarting a
board.
Changing a command is quite painful since all environment scripts will
be broken. I don't think reset is used in the environment, but the
API change to the mount command always nags me when using a new barebox
which has an older environment in flash. I think we really have to be
more careful when changing commands.
reset means reset the screen in linux
and I check nearly no one use reset in the env
execpt sam9g45 and defaultenv2
when I ask to do not update the var to pass the arch number on arm you give
the invert comment env evolve and we do not want to loose tis freedom
You are right, but still we have a problem in this area and I wanted to
mention it. One way out could for example be that we introduce some
version counter which we increase when incompatible changes occur. Then
we could fall back to the default env. I haven't thought that to an end
though.
agreed, I've add such info in the env for it's own format
maybe with a question to the end use the first time with a timeout
if he really want to keep the current one
Best Regards,
J.
_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox